viernes, 30 de mayo de 2008

Dia 3 (Proyecto)

Mayo Jueves 29

Este día se noto el compromiso que todos teníamos con el proyecto, montamos DNS en varias maquinas y se le explico el proceso a unos compañeros que no son del DNS.

Montamos el DNS esclavo y aunque al principio no tenia conectividad con el maestro se logro transferir la información del maestro al esclavo. Intentamos crear los reenviadores pero no nos dio, nos planteamos dejarlo para el viernes y no irnos hasta lograrlo.

Dia 2 (Proyecto)

Mayo Miercoles 28

No pusimos de acuerdo para investigar e informarnos sobre el DNS esclavo y como sincronizar DNS con DHCP.
Para ponerlo en practica el jueves.

Dia 1( Proyecto)

Mayo Martes 27

Reunion extraordinaria para informarnos sobre el proyecto. Este dia no trabaje en mi parte del proyecto que es el DNS, pero estube con los integrandes de la red y estubimos probando conectivida.

COMANDOS PARA LINUX

Se ejecutan para crear directorios, usuarios entre otros

Mkdir:Crear Directorios

Cd: Entra al directorio

Cd /: Lleva directamente a la raíz

Cd.. Salir del directorio

Touch:Para crear archivos

Cp: Copiar archivos

Mv: Mueve archivos

Cat: Visulizacion del texto del archivo

Pico: Editar texto de archivo

Clear ó Control + L:Limpia la pantalla

Pwd: Muestra la ruta de la ubicación

Rm: Borra archivosr

Mdir:Borra directorios

Man:Parametros de comando, manual

Q: Salir de parametros de comando, manual

Date: Hora y fecha

sudo bash: se convierte en administrador

Cal: Calendario

Ps aux: Lista de procesos ejecutados en ese momentops

Aux altgr 1 more: Retrasa el pantallaso de la lista

Kill pid (# identficacion): (mata) el proceso

Kill -9 pid (# identificacion): Exterminador

Xkill:Termina entorno grafico


Traceroute: Numero de saltos hasta el destino

ls: muestra la lista de archivo y directorios

Shutdown -r now: Reiniciar el sistema (sin tiempo)

Shutdown p x: Apaga en tiempo determinado el sistema (x es la programacion del tiempo de apagado en minutos)

Shutdown h: apaga el sistema

Adduser: nuevo usuario

Userder: nombre de usuario

Passwd: combiar el password

COMANDOS PARA CONFIGURAR WINDOWS

Mkdir: Para crear diectorios.

Dir: Permite visualizar los directorios, y la ruta en la cual se encuentra cada uno.

Cls: Permite borrar la pantalla.

Cd: Cambia de un directorio a otro y accede al directorio.

Edit: Permite editar archivos.

Copy: Copia uno o mas archivos en otro lugar.

Xcopy: Copia múltiples archivos desde un directorio a otro.

Type: Permite ver el contenido de un archivo de texto.

Move: Sirve para renombrar un archivo.

Rmdir: Sirve para eliminar un directorio.

Tree: Muestra la estructura o el árbol de directorios de la unidad.

Time: Permite ver la hora del Sistema.

Date: Muestra la fecha del Sistema.

Cd .. Retrocede directorios.

Color (desde la letra A hasta la F) Establece los colores de primer plano y fondo predeterminados de la consola.

procesos utilizamos

tasklist:Muestra la lista de procesos
taskill: /pid (# de identificador) - termina el proceso.

Para Apagar:

shutdown t x : Apaga el sistema en determinado tiempo (x es el tiempo a programar en sg) shutdwon - a : cancela el apagado del sistema.

Crear usuarios

Net User: Permite la visualización de las cuentas existentes
Net User + nombre usuario + contraseña /add : Crea una cuenta de usuario
Net User / + nombre del usuario:Elimina una cuenta de usuario

COMANDOS EN WINDOWS

PING

Un ping (Packet Internet Grouper) se trata de una utilidad que comprueba el estado de la conexion con uno o varios equipos remotos por medio de los paquetes de solicitud de eco y de respuesta de eco (definidos en el protocolo de red ICMP) para determinar si un sistema IP específico es accesible en una red. Es útil para diagnosticar los errores en redes o enrutadores IP.

Muchas veces se utiliza para medir la latencia o tiempo que tardan en comunicarse dos puntos remotos, y por ello, se utiliza entre los aficionados a los juegos en red el término PING para referirse al lag o latencia de su conexión.

Existe otro tipo, Ping ATM, que se utiliza en las redes ATM (como puede ser una simple ADSL instalada en casa) y, en este caso, las tramas que se transmiten son ATM (nivel 2 del modelo OSI).

Este tipo de paquetes se envían para probar si los enlaces ATM están correctamente definidos.

El comando 'ping' es ampliamente utilizado para verificar el estado de las conexiones entre dos PC dentro de una red.

Se suele utilizar digitando en la línea de comandos: ping + IP_del_otro_pc

PARÁMETROS

PRUEBAS

Ping –t (dirección IP)










Ping –n (# de peticiones) (dirección IP)







Ping –a (dirección IP)



Ping –l (tamaño) (dirección IP)






Ping –f (dirección IP)







Ping –i (# de tiempo de vida de 1 a 255) (dirección IP)






Ping –v (# tipo de servicio) (dirección IP)






Ping –r (# de cuenta de 1 a 9) (dirección IP)






Ping -s (sello de hora # de 1 a 4) (dirección IP)






Ping –w (# tiempo de espera) (dirección IP)



TRACERT

Es una herramienta de diagnostico de redes que permite seguir la pista de los paquetes que van desde un host (punto de red) a otro. Se obtiene además una estadistica del RTT o latencia de red de esos paquetes, lo que viene a ser una estimación de la distancia a la que están los extremos de la comunicación. Esta herramienta se llama traceroute en UNIX y linux, mientras que en Windows se llama tracert

PARAMETROS




PRUEBAS

Tracert –d (nombre de destino)






Tracert –h (# saltos) (nombre de destino)






Tracert –j (nombre de destino)






Tracert –w (# tiempo de espera) (nombre de destino)


NSLOOKUP

Es un programa, utilizado para saber si el DNS está resolviendo correctamente los nombres y las IPs. Se lo utiliza con el comando nslookup, que funciona tanto en windows como en unix para obtener la dirección IP conociendo el nombre, y viceversa

PARAMETROS

nslookup (sitio que desee)

nslookup (dirección que desee)

PRUEBAS

nslookup google.com



Nslookup 209.85.165.104


NETSTAT

Es una herramienta de linea de comandos que muestra un listado de las conexiones activas de un ordenador, tanto entrante como saliente.

La información que resulta del uso del comando incluye el protocolo en uso, las direcciones IP tanto locales como remotas, los puertos locales y remotos utilizados y el estado de la conexión. Existen, además de la versión para línea de comandos, herramientas con interfaz gráfica (GUI) en casi todos los sistemas operativos desarrollados por terceros.

La sintaxis y los parámetros de la herramienta pueden variar entre los diferentes sistemas operativos que la implementan. En sistemas basados en Unix (esto incluye Linux y Mac OS X, entre otros), se puede usar el comando man netstat para visualizar la ayuda del comando. Otras formas de ver una lista de parámetros pueden ser con el parámetro -h o también --help (en los sistemas que cumplan con la norma POSIX) o con /? (en los sistemas Windows y MS-DOS).

PARAMETROS



PRUEBAS

Netstat -a







ntstat -b



Netstat -e



jueves, 29 de mayo de 2008

IPCONFIG

En Windows es una utilidad de linea de comandos que muestra la configuración de red actual de un ordenador local (dirección IP, mascara de red, puerta de enlace asignada a la tarjeta de red, etc ), así como controlar el servicio Windows que actúa como cliente DHCP.

ipconfig en Mac OS X es una utilidad de línea de comandos que puede ser usada para controlar los clientes BootP y DHCP. Como en otros sistema operativos basado en UNIX, en Mac OS X también se puede utilizar el comando ifconfig para un control más directo sobre las interfaces de red.

PARAMETROS

/all         muestra toda la información de configuración.
/release     libera la dirección IP para el adaptador específico.
/renew       renueva la dirección IP para el adaptador específico.
/flushdns    purga la caché de resolución de DNS.
/registerdns actualiza todas las concesiones y vuelve a registrar los
             nombres DNS.
/displaydns  muestra el contenido de la caché de resolución DNS.
/showclassid muestra todas las id. de clase dhcp permitidas para
             este adaptador.
/setclassid  modifica la id. de clase dhcp.

PRUEBAS

Ipconfig /all


Ipconfig /release

Ipconfig /renew

TELNET

El comando telnet es usado para comunicarnos con otro host usando el protocolo TELNET. Si el comando telnet es ejecutado sin un host como argumento, este entrará en un modo comando, indicado en el prompt como " telnet> ". En este modo telnet acepta y ejecuta una gran variedad de comandos, los cuales son listados en las páginas de su manual. Si este es invocado con argumentos (ósea con un host predefinido nos establece una conexión inmediata con la otra máquina mediante login y password. Un gran detalle sobre este comando es que no encripta la información que es enviada, lo que significa que todo se envía en texto plano, incluso las contraseñas. Un ejemplo de esto sería:

Una de las cosas interesante que logramos mediante un conexión telnet a través de un terminal en X como por ejemplo xterm es la ejecución de programas X en la computadora con la que establecimos una comunicación remota y mostrar la salida de este comando o en este caso la interfáz del programa en nuestra máquina. Para una explicación más detallada de esto puedes ver la sección "Exportando llamadas" en el capítulo 6 o puedes consultar las páginas del manual.

PARAMETROS

open host: abre una conexión al host llamado. Si el número de puerto no es especificado, telnet intenta de conectar el servidor telnet desde el puerto default. La especificación del host puede ser tanto el nombre de un host o una IP

close: cierra una sesión TELNET y te regresa al modo de comando.
quit: cierra cualquier sesión TELNET abierta y sale de telnet. Un fin de archivo (end-of-file) (en modo de comando) también cerrará una sesión y saldrá.

Ctrl-z: suspende telnet. Este comando sólo trabaja cuando el usuario está usando csh o la el ambiente de aplicación BSD versión de ksh.

status:
muestra el status actual de telnet.
display:
lista las propiedades del argumento dado.
? [comand]:
proporciona ayuda. Sin argumentos, telnet muestra un sumario de ayuda. Si un comando es especificado, telnet mostrará la información de ayuda sobre el comando.
send:
envía uno o más secuencias de caracteres especiales a un host remoto. Los siguientes son argumentos los cuales pueden ser especificados (más de algún argumento puede ser especificado en un tiempo).
escape:
envía el caracter telnet escape.
synch:
envía la secuencia SYNCH TELNET. Esta secuencia causa que el sistema remoto descarte todo lo previamente tecleado como entrada, pero que todavía no haya sido leído. Esta secuencia es enviada como un dato urgente TCP.
brk:
envía la secuencia TELNET BRK (break -rompimiento), la cual puede tener significado para el sistema remoto.
ip:
envía la secuencia TELNET IP (interrupción de proceso), la cual debe causar que el sistema remoto aborte en proceso que se esta corriendo.
ao:
envía la secuencia TELNET AO (abortar salida), la cual puede causar al sistema remoto que nivele todas las salidas del sistema remoto a la terminal del usuario.
ayt:
envía la secuencia TELNET AYT (are you there- estas ahí), el cual el sistema remoto puede o no responder.
ec:
envía la secuencia TELNET EC (erase character- borrar caracter), la cual puede causar al sistema remoto a borrar el último caracter tecleado.
el:
envía la secuencia TELNET EL (erase line - borrar línea), la cual causa que el sistema remoto borre la línea anterior escrita.
ga:
envía la secuencia TELNET GA (go ahead - adelante), la cual probablemente no tiene significado para el sistema remoto.
nop:
envía la secuencia TELNET NOP ( no operación - no operación).

mode:
Cambia el modo de entrada del usuario de telnet al Modo. El huésped remoto es preguntado por el permiso para introducirse en el modo solicitado. Si el huésped remoto es capaz de entrar en ese modo, el modo solicitado se introduce.

ARP

Muestra y modifica las tablas de conversión de direcciones IP en direcciones ísicas que utiliza el protocolo de resolución de direcciones (ARP).

PARAMETROS EN WINDOWS

-a Pide los datos de protocolo actuales y muestra las entradas ARP actuales. Si se especifica inet_addr, sólo se muestran las direcciones IP y física del equipo especificado. Si existe más de una interfaz de red que utilice ARP, se muestran las entradas de cada tabla ARP.
-g Igual que -a.
-v Muestra las entradas actuales de ARP en modo detallado. Se mostrarán todas las entradas no válidas y las entradas en la interfaz de bucle invertido.
inet_addr Especifica una dirección de Internet.
-N if_addr Muestra las entradas ARP para la interfaz de red especificada por if_addr. -d Elimina el host especificado por inet_addr. inet_addr puede incluir el carácter comodín * (asterisco) para eliminar todos los host.
-s Agrega el host y asocia la dirección de Internet inet_addr con la dirección física eth_addr. La dirección física se indica como 6 bytes en formato hexadecimal, separados por guiones. La entrada es permanente.
eth_addr Especifica una dirección física.
if_addr Si está presente, especifica la dirección de Internet de la interfaz para la que se debe modificar la tabla de conversión de direcciones. Si no está presente, se utilizará la primera interfaz aplicable.

SSH

Ofrece comunicación encifrada y segura entre dos sistemas de red más segura. Este comando entra a reemplazar a telnet,rlogin,rsh.

PARAMETROS:

sshd_config: fichero que contiene los parámetros de configuración del servidor. Más adelante veremos algunos de esos parámetros.
ssh_config: fichero de configuración del cliente SSH.
ssh_host_rsa_key: clave RSA privada la máquina.
ssh_host_rsa_key.pub: clave RSA pública.
ssh_known_hosts: claves públicas RSA de otras máquinas.
~/.ssh/authorized_keys: claves públicas del usuario para la autenticación

CONFIGURAR ROUTER

router>enable (para entrar a modo privilegiado)
router#config terminal
router(config)#hostname (ejemplo"cali")
cali(config)#exit (salir)
cali#write (guardar)
cali#config terminal
cali(config)#interface f0/0 + (nombre de la interface a configurar)
cali(config-if)#ip address + Ip + mascara "de la interface" (para darle a la interface una Ip)
cali(config-if)#no show down (para subir la direccion)

Se hace igual para las interfaces seriales pero a estas se les debe configurar el clock rate.

CONFIGURAR CLOCK RATE

En una interfaz entre dos routers se configura una interfaz, si hay 3 se configuran dos clock rate

cali#config terminal
cali(config )#interface s0/1/0
cali(config-if)#clock rate 64000
cali(config-if)#no show down
cali#write (guardar)
cali#exit (salir)

Para ver la configuracion
cali#show running

Para ver las interfaces
cali#show ip interface brief

CONFIGURACION DE ENRUTAMIENTO ESTATICO

cali#show ip route (para ver las direcciones de red)
cali#config terminal
cali(config)#ip router + ID de red (donde se quiere llegar) + mascara + interfaz (por donde va a salir)

El proceso hace en cada roueter

Cuando tiene una solo interfaz se configura de la siguiente manera:
En vez de poner una por una se coloca en identificador de red 0.0.0.0 y la mascara 0.0.0.0 y la interface y asi el router permite la comunicacion con las demas redes

cali#wr (guardar)
cali#exit (salir)

ENRUTAMIENTO DINAMICO

Se utiliza el protocolo rip aunque hay mas protocolos que son para enrutamiento dinamico, este es el mas basico.

Entrar a modo router privilegiado
router(config)#router rip (para entrar al modo de configuracion dinamica rip)
router(configure-router)#network+ ID de red
router(configure-router)#network + mascara
(Todas las ID de las redes que esten directamente conectadas al router)

Ejemplo
router(configure-router)#network 192.168.24.0
router(configure-router)#network 255.255.255.0
(Solo se configuran las redes que se deseen que los demas conoscan)
router#wr (guardar)
routet#exit

El proceso se repite con cada router.

CONFIGURAR PASSWORD

router (config)#enable passsword y (el nombre del password)
router# wr (guardar)
router#exit (salir)

COMO TUMBAR CONTRASEÑAS

Reiniciamos el router: ctrl + inter

Entramos al modo rommon:
rommon1>confreg 0x2142
rommon2>reset (para reiniciar)

router>enable
router#copy start running (copiar la configuracion anterior)
router#show running

Despues se configura un nuevo password para hacerlo se hace "el proceso anterior acerca de la configuracion del password"

Antes de salir
router(config)#config-register0x2102 (para que nos acepte la contraseña)
router#wr (guardar)
router#reload (salir)

miércoles, 28 de mayo de 2008

PACKET TRACER

RED


BOGOTA

hostname bogota
!
interface FastEthernet0/0
ip address 192.168.24.33 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.65 255.255.255.224
duplex auto
speed auto
!
interface Serial2/0
ip address 192.168.23.1 255.255.255.252
!
interface Serial3/0
no ip address
shutdown
!
router rip
network 192.168.24.0
!
ip classless
ip route 192.168.24.96 255.255.255.224 192.168.23.2
ip route 192.168.24.128 255.255.255.224 192.168.23.2
ip route 192.168.24.160 255.255.255.224 192.168.23.2
ip route 0.0.0.0 0.0.0.0 Serial2/0

MEDELLIN

hostname medellin
!
interface FastEthernet0/0
ip address 192.168.24.97 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.24.129 255.255.255.224
duplex auto
speed auto
!
interface Serial2/0
ip address 192.168.23.2 255.255.255.252
clock rate 4000000
!
interface Serial3/0
ip address 192.168.22.1 255.255.255.252
clock rate 4000000
!
ip classless
ip route 192.168.24.32 255.255.255.224 192.168.23.1
ip route 192.168.24.64 255.255.255.224 192.168.23.1
ip route 192.168.24.160 255.255.255.224 192.168.22.2
ip route 0.0.0.0 0.0.0.0 Serial3/0
ip route 0.0.0.0 0.0.0.0 Serial2/0

CALI

hostname cali
!
interface FastEthernet0/0
ip address 192.168.24.161 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 192.168.22.2 255.255.255.252
!
interface Serial3/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.22.1
ip route 0.0.0.0 0.0.0.0 Serial2/0

VNC

Virtual Network Computing (Computación en Red Virtual)

VNC
es un programa de software libre basado en una estructura cliente-servidor el cual nos permite tomar el control del ordenador servidor remotamente a través de un ordenador cliente. También llamado software de escritorio remoto. VNC permite que el sistema operativo en cada computadora sea distinto: Es posible compartir la pantalla de una máquina de "cualquier" sistema operativo conectando desde cualquier otro ordenador o dispositivo que disponga de un cliente VNC portado. El programa servidor suele tener la opción de funcionar como servidor HTTP para mostrar la pantalla compartida en un navegador con soporte de Java. En este caso el usuario remoto (cliente) no tiene que instalar un programa cliente de VNC, éste es descargado por el navegador automáticamente.
El programa muestra una captura de imagen de la computadora remota cada un período determinado de tiempo. De esta manera un usuario puede ver exactamente qué enentos se producen en otra computadora y también controlarlos (si el programa está configurado para permitir controlarla).

VNC dependiendo de la
plataforma, por lo tanto los sistemas operativos de ambas computadoras pueden ser distintos.

Además del control remoto de otra computadora, permite, por ejemplo, que un profesor pueda explicar desde su computadora algún tema y todos sus alumnos puedan ver los resultados constantemente actualizados en sus propios
monitor.

Originalmente VNC fue desarrollado en el Reino Unido, en los laboratorios de Olivetti & Oracle Research en Cambridge. Luego, en 1999, el laboratorio es adquirido por AT&T, que lo desarrolló completamente. El laboratorio fue cerrado en 2002. Luego pasó a la compañía RealVNC, que lo convirtió en un programa de código abierto y libre distribución.

Por ser de código abierto, existes múltiples implementaciones con distintas características, y que permiten mayor o menos seguridad.

INSTALACION VNC

1. Se debe descargar el VNC.









2.
Como toda aplicación de control remoto, RealVNC tiene dos componentes: el servidor (que se instala en el equipo controlado) y el cliente (que se usa en el equipo que va a controlar).

La instalación del programa se reduce a la secuencia de pulsaciones de Next - Next - Next... Install. Las opciones marcadas por defecto son adecuadas. Casi al final de la copia de archivos en el disco duro, aparecerá un menú como éste:





















3.
Deben pulsar el botón Configure y escribir dos veces la contraseña con la que accederan desde el exterior. Debido a que su PC servidor quedará a merced de quien logre el acceso, esta contraseña debe ser muy sólida. Es recomendable que tenga al menos ocho caracteres (cuantos más, mejor) y que combine mayúsculas, minúsculas, números y símbolos, de forma aleatoria. Usar palabras de diccionario, en cualquier idioma, es equivalente a abrir las puertas de su ordenador a media internet.

Contraseña adecuada: $rfdEe·3454wSCoj)=)
Contraseña inadecuada: En un lugar de La Manch











4.
Configuración del servidor

Si lo estan ejecutando en un Windows 2000/XP/2003/posterior, es recomendable usar el Service Mode (modo servicio). En el menú Inicio >Programas/Todos los programas > RealVNC > VNC Server 4 (Service Mode)
encontraran cinco opciones:

  • Register y Unregister sirven para añadir o eliminar RealVNC de la lista de servicios en Panel de Control > Herramientas Administrativas > Servicios. Habitualmente no tendran que tocarlas para nada.
  • Start y Stop sirven para arrancar o detener el servicio. Esto también lo pueden hacer desde Herramientas Administrativas.
  • Por último, con Configure podran modificar las opciones.

Escogiendo esta última opción, se encontraran con un menú familiar: es el mismo que ha aparecido en la instalación. Si no querieren complicarse, lo único que tienen que modificar aquí es lo siguiente: en la pestaña Authentication, desmarcar la casilla Prompt local user to accept connections y aceptar para salir del menú. Con esto ya podran pasar directamente a la configuraciòn del cliente.

5. Si quieren le configurar el servidor, las opciones significativas son:

Desktop: aquí pueden desactivar algunos adornos del sistema operativo controlado con el fin de mejorar el rendimiento del control remoto, si tanto las limitaciones en la potencia de los equipos como la capacidad de su conexión pueden ralentizarlo. Con Remove wallpaper y Remove background pattern desactivaran respectivamente la imagen y el fondo del escritorio de Windows; mientras que con Disable user interface effects eliminaran efectos como el que desaparezcan los menús "difuminándose" y pijadas similares.








Authentication: es la pestaña donde anteriormente hemos introducido la contraseña. Aquí nos encontramos con otra importante opción: Prompt local user to accept connections. De forma predeterminada está marcada, lo que implica que toda conexión externa ha de ser autorizada por alguien que esté sentado frente al PC servidor. Obviamente, si vamos a conectarnos a nuestro propio ordenador mientras estamos fuera, hay que desmarcar esta
opción.







Connections: en esta sección, apartado Accept connections on port, podemos cambiar el puerto por el que escucha el servidor. Inicialmente lo hace por el 5900 (TCP), pero es recomendable cambiarlo por razones de segurida. Cualquier puerto desde el 1024 hasta el 65535. debería servir. Nota: es importante recordar que el cliente está preconfigurado para usar ese puerto 5900; si lo cambiamos, debemos tenerlo en cuenta cuando nos conectemos a distancia (más adelante quedará explicado).

Disconnect idle clientes after (seconds) desconectará todos los clientes transcurrido el tiempo en segundos que indiquemos. No es mala política de seguridad configurarlo a una cifra menor de la hora (3600 segundos) a la que inicialmente está puesto.

Por último, si no vamos a usar el cliente en Java, podemos desconectar la casilla Server Java viewer via HTTP on port y cerrar así otra puerta.

La sección Access Control es muy interesante: nos da la posibilidad de filtrar las conexiones
entrantes por IPs, aumentando así la seguridad al aceptar sólo determinados accesos. Por ejemplo, imaginemos que la IP estática de nuestra oficina es 80.80.80.80 y queremos conectarnos desde allí a nuestra casa, donde tenemos el servidor. Los pasos a seguir serían los siguientes:
  • Seleccionamos la crucecita del listado y pulsamos el botón Remove. Esta regla inicial autoriza el acceso a todo el mundo (que sepa la contraseña, claro), y no queremos tal cosa.
  • Una vez vacío el listado, pulsamos el botón Add. Aparecerá un menú con tres opciones y una casilla. En ésta hemos de introducir la IP en cuestión: 80.80.80.80. Y la opción que debemos seleccionar es Allow (autorizar). Al aceptar, se habrá añadido al menú con una cruz delante.
Las otras opciones son Deny (rechazar) y Query (preguntar primero). Esta última puede ser útil en el caso de que, por ejemplo, algún amigo informático nos esté echando una mano con el PC, pero no queramos dejarle acceso permanente. Cada vez que quiera conectarse, deberá obtener primero nuestra autorización. Las IPs en modo Query se añaden con un símbolo de interrogación (?) al listado, mientras que las Deny lo hacen con un menos (-). Todas las IPs que no coincidan con alguna del listado se rechazarán.

Nota: para volver a dejar paso a todo el mundo, como estaba al principio, borraremos todas las reglas existentes y añadiremos la siguiente: 0.0.0.0 Allow.

Si el equipo al que queremos dar paso no tiene una IP estática, siempre podemos autorizar a su rango probable, añadiendo una máscara a la IP. Pero como explicar este método alargaría en exceso este tutorial, os invitamos a que lo preguntéis en el foro Programas en general.

Con esto ya tendremos nuestro servidor listo para aceptar órdenes desde el exterior.

6.
Configuración del cliente

Una vez instalado, lo arrancaremos desde Inicio > Programas/Todos los programas > RealVNC > VNC Viewer 4 > Run VNC Viewer.


No hay mucha complicación en este menú. En la casilla debemos meter la IP o dominio del servidor.

Si en éste hemos cambiado el puerto 5900 por otro, debemos añadir a la IP el símbolo de dos puntos (:) y el puerto nuevo. Ejemplo: 100.90.100.90:5901 para conectarse al servidor de IP 100.90.100.90 cuyo RealVNC escucha por el puerto 5901. O usuario.dyndns.org:5901 si usamos algún redireccionador de IPs dinámicas, en este caso DynDNS.

Después de introducir la contraseña en el siguiente menú, ya tendremos control sobre el servidor.

En el botón Options del primer menú encontraremos algunas opciones interesantes:

  • Colour & Encoding: en Color level podremos ajustar el número de colores que queremos visualizar en la pantalla. A mayor número de colores, más ancho de banda se requiere.
  • Inputs: aquí configuraremos qué órdenes aceptará el servidor: las del ratón (send pointer); las del teclado (send keyboard); que el contenido de nuestro portapapeles pase al servidor (send clipboard); al contrario, que el portapapeles de la máquina controlada pase al nuestro (accept clipboard) y las teclas especiales como la de Windows o la de Aplicación (pass special keys). También encontraremos una tecla Menu Key (inicialmente F8) para poder sacar el menú cuando nos encontremos en el modo "pantalla completa".
  • En los otros dos menús no hay nada especialmente significativo: en Misc. podemos configurar algunas opciones secundarias, mientras que en Load/Save tendremos la posibilidad de guardar o cargar configuraciones.

7. Uso del cliente

Mientras estemos manejando remotamente otro equipo, podemos pulsar la barra de título con el botón derecho del ratón o dar a la tecla Menu Key (normalmente F8) para sacar el menú de opciones. Las más llamativas son:

  • Full screen: para pasar a pantalla completa.
  • Ctrl/Alt: escogiendo una de las dos, enviaremos la pulsación de esa tecla al PC remoto.
  • Send Ctrl-Alt-Del. La pulsación de Control+Alt+Supr (Del en teclados ingleses) seguirá afectando a nuestro equipo, no al remoto. Si queremos enviar esta orden al servidor, deberemos usar esta opción.
  • Refresh screen: en conexiones lentas o saturadas, a veces tendremos que usar esta opción para actualizar la imagen.

9. Routers y firewalls

Como buen servidor, el correcto funcionamiento de RealVNC server está condicionado a que proxies, routers, gateways, firewalls y antivirus admitan la comunicación que requieren los clientes. Por tanto, debemos configurar aquéllos para permitir todas las conexiones entrantes al puerto local TCP 5900 (o el que hayamos escogido).

En los routers, habremos de hacerlo mapeando dicho puerto a la IP local del servidor. En cuanto a firewalls por software y antivirus, tenemos la opción tanto de dar acceso completo al RealVNC server en sentido entrante, como de admitir por puertos.

MI HABITACION

Plano hecho en "VICIO"